
12.0.0 New Feature Release Notes 

Notable 

SIS 

General 

Added the ability to quickly select a student or staff member and view their student or user 
record without having to conduct a search. A pull-down is available at the top-left corner of 
every screen. Once the pull-down is opened, click the Staff or Students buttons to include or 
exclude students and staff from the list of users. Use the Filter box to quickly locate the desired 
student or staff member using a full or partial name or ID number. Once the student or staff 
member is selected, the Student Info or User Info screen is opened. In ERP, a similar pull-down 
is available to select employees. 

• Added the “Back to Search Results” button to the navigation arrows in the student/user info 
section of the header. The button displays when a student/user has been selected from a 
search from the portal or search screen. 

• Added the ability to clear the “Search Results” when a student/user is closed or deselected 
(when the X is clicked). 

• The Staff and Students tabs display depending on users’ profile permissions set via Users > 
Profiles > Students tab and/or Users tab. Users will have access to the Staff tab if they have 
access to User Info and will have access to the Students tab if they have access to Student 
Info. 
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• Added the ability to search for “Inactive Students” and/or “Inactive Staff” by selecting the 
corresponding tabs. 

• Added the ability for users to hover over students’ photos in order to view additional 
information, which is determined by the selection made via Users > My Preferences > 
Columns in Student Lists. 

 See Searching for Students and/or Portal for detailed information in SIS. See Portal 

and/or Employee for detailed information in ERP. See Portal for detailed information in 

the Teacher Portal. 

On the Student Info and User Info screens, the student’s or user’s name that had previously 
displayed at the top-left corner of the screen has been removed as it is now displayed in the 
header. The General Information that previously displayed when clicking the student or user’s 
name is now displayed in its own Primary Info category. The student photo is now edited from 
Primary Info. Individual student badges are also generated from Primary Info. 

• The arrows that previously displayed near the Save button at the top-right corner of the 
screen to navigate to the next or previous student or user have been replaced by the arrows 
in the student/staff pull-down in the header. 
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• Additionally, results from the last search are added to the pull-down. The options from the 
search results are given an additional tag of “Search Results” so users can filter through 
them or ignore them and find users outside the search results. 

 The Select Student/Staff search feature is an improvement upon the prior Quick Pick 

pull-down in Student Info and User Info. Student and staff search results will be limited 

to the school selected at the top-right of the screen. For example, a staff member with 
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access to all schools (no schools selected in their User Permission record) will not 

appear in search results. 

 See Student Info and User Info for detailed information. 

Redesigned the menu for teachers for improved usability. The new menu provides quick access 
to the programs teachers use the most, such as Take Attendance, Seating Chart, and 
Gradebook. Menu items with an arrow can be clicked to expand the menu display. For example, 
click Students to expand the menu and access the Demographics, Schedule, Requests, and 
other student screens. Reports are now housed under the Reports section of the menu instead 
of their specific module menus. 

 See Teacher Portal for detailed information. 
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Setup 

Imports (New) 

Added the new “Imports” screen, which replaces the following screens: Match Students - Admin 
Panel, Match Students - School Panel, AP Test Parser, Import Tools, and Importer. Note: There is 
a transition plan in place for these screen replacements. At this time, these screens have not 
been removed from Focus. Districts should contact their support team (Project Coordinator or 
Account Executive) for details on how to transition from the original screens to the new Imports 
screen. 

• Added the following profile permissions, which determine the tabs the users have access to 
utilize: Imports, Import Tools, Student Match Files, Reports, Settings. 

• Added the “Imports” tab, which allows users to upload a file from the computer or from the 
local server, select the correct format, and from different tools, including: 
◦ Import File: To import the contents from the uploaded file into Focus. 
◦ Student Match: To find student_ids for the students in the uploaded file. 
◦ Create Table from File: To create a database table using the data from the uploaded file. 

• Added the “Student Match Files” tab, which allows users to review student matches started 
and complete the process. A Student Match import must first be conducted before users can 
view the process from this tab. The Student Match import tool is used to find student_ids for 
the students in an uploaded file. 

• Added the “Reports” tab, which allows users to review a report of imports processed 
including date, time, import tool, file, etc. 

Page 512.0.0 New Feature Release Notes



• Added the “Settings” tab, which allows users to review and enable “Import Tool Settings,” 
review and set “Conversion Fields,” create and edit file mapping “Templates,” and view and 
create “File Parsers.” 

 See Imports for detailed information. 

Students 

Communication (New) 

Added the “Communication” module, which replaces the Portal Messages, Messenger, and 
Phone Communication screens. Note: The features within Communication, such as Phone 
Communication (Call-Out System) and Translations, require additional purchases. Contact the 
district's support representative to set up a demonstration. 

• Added Communication profile permission to Users > Profiles > Students tab, which includes 
the following permissions:Communication, Send Messages, Include Profile in Messaging 
Search, Send SMS, Announcements (View and Edit), Templates Created by Others (View and 
Edit), Publish Templates, Attendance Messages, Academic Record, and Phone Calls. Note: 
Some of these features require additional purchases based on add-on modules, such as the 
Call Out System. Contact the district's support representative to set up a demonstration. 

• Added the “Compose” tab, which allows users to create a message (Messenger) to selected 
students and/or staff members, use a template, create a new announcement (Portal 
Messages), and/or create a new template. 
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◦ Messages can be created manually and be assigned a Letterhead template, flagged as a 
Secure Message, added to the Log Record, and enabled to allow student replies. 

◦ Messages can also be discarded, saved as drafts, printed, scheduled to be sent at a later 
date and time (or set up as Recurring), and sent. 

◦ Files, multimedia messages, recorded messages, and text-to-speech messages can be 
added to messages, as well. Note: Some of these features, such SMS and Call features, 
require additional purchase based on add-on modules, such as Call Out System. Contact 
the district’s support representative to set up a demonstration. 

◦ Added the ability to send messages to Students, Student Personal, Primary Contacts, All 
Contacts, Once Per Family, Students & Primary Contacts, Students & All Contacts, and 
Teachers Of. 
▪ The “All Contacts” option includes all users and/or persons in a student’s addresses & 

contacts. The “Primary Contacts” option limits to the contacts marked as custody. 
▪ Updated the “Once Per Family” option so students must be linked to contacts, 

contacts must have custody of one of the linked students, and contacts must have an 
email address. 

▪ Updated so if a student does not have a contact and contacts are selected as the 
recipient, the student will get the message instead. 

• Added the “Templates” tab, which gives users the ability to create templates and use said 
templates to generate messages to students and/or staff (previously known as Messenger 
and Phone Communication). 
◦ Templates include a Title, Letterhead, Profiles, Schools, Attach to Tab, Academic Record, 

and a Secure Message option, which flags messages as secure and requires users to log 
into Focus in order to view the message. 

◦ Emails, files, multimedia messages, recorded messages, and text-to-speech messages 
can be added to templates, as well. Note: Some of these features, such SMS and Call 
features, require additional purchase based on add-on modules, such as Call Out System. 
Contact the district’s support representative to set up a demonstration. 

◦ The upgrade to version 12 will convert existing Print Letters & Send Emails to Templates, 
available through the Templates tab within Communication. The migration for Print 
Letters & Send Emails is a one-time migration. Changes made to a Print Letter & Send 
Email Template after the migration will not be reflected in Communication, and vice 
versa. 
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• Added the “Announcements” tab (previously Portal Messages), which allows users to enter a 
Title, assign Profiles, assign Grade Levels, establish an Active time frame for when the 
message should display on select Portal screens, and assign Schools. From the 
Announcements tab, new announcements can be created and posted to the selected profile 
users’ portals. Announcements can also be discarded and posted. 
◦ The Announcement itself is entered in the Announcement tab. 
◦ Emails (messages), files, test messages (SMS), recorded messages and text-to-speech 

messages (Call) can be sent with announcements, as well. Note: Some of these features, 
such SMS and Call features, require additional purchase based on add-on modules, such 
as Call Out System. Contact the district’s support representative to set up a 
demonstration. 

◦ Updated users’ ability to edit announcements created by other users, which is now 
determined by the Schools assigned to the announcement and the schools to which said 
user has access. In addition, users can only create announcements for schools to which 
they have access, which is reflected in the Schools pull-down. 
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• Added the “Inbox” tab, which houses all incoming messages from which a chat is displayed 
with all incoming and outgoing messages between the user and the applicable users or 
students. 
◦ Upon sending messages from the Inbox tab, users have the option to create a new 

message, schedule a time and date for the message to be sent, and send messages 
instantly, in addition to viewing incoming messages. 

◦ When messages are received, a Portal Alert displays the number of unread messages; 
when clicked, Focus navigates to the Inbox where unread messages display users’ names 
and the number of unread messages. 

• Added the “Sent” tab, which houses all sent messages from which a chat is displayed with all 
outgoing and incoming messages between the user and the applicable users or students. 
◦ Upon sending messages from the Sent tab, users have the option to create a new 

message, schedule a time and date for the message to be sent, and send messages 
instantly. 

• Added the “Scheduled” tab, which houses all messages that have been scheduled to be sent 
out at a later date and/or time. Scheduled messages can be sent manually before their 
scheduled date and time, as needed, as well as created and edited exactly like a new 
message. 
◦ Added the “Communication Processing” scheduled job to Setup > Scheduled Jobs, which 

locates all scheduled messages being held in the queue and prepares them to be sent 
out. Scheduled messages will not be sent out without the execution of the 
Communication Processing scheduled job. Each time the job is set to run, it will send out 
any messages scheduled for the time at or before the current time of processing. Note: 
The Communication Processing job replaces the old Phone Communication Processing 
job. 
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• Added the “Drafts” tab, which houses all messages saved as drafts. From the Drafts tab, 
users can schedule, send, or edit messages, as well as perform all other tasks as if creating a 
new message. 

• Added the “Settings” tab, which allows users to enable various settings applicable 
throughout the Communication module. 
◦ Users can determine if receipts can reply to emails (messages) sent or if a “do not reply to 

this email address” email address is displayed upon messages being sent. 
◦ Users can add an Email Signature that will display on all sent messages. 
◦ The Attendance table now displays on the Settings tab, which was previously housed in 

Phone Communication; functionality remains the same. Note: This feature still requires 
the purchase of the Call Out System. 

• Added “Purchased Communication Translation," which can be enabled by Focus once 
purchased by the district. This setting allows districts to utilize the translation feature 
available in Communications. Note: This feature requires an additional purchase. Contact 
the district’s support representative to set up a demonstration. 
◦ The Communication module allows users to manually translate messages into over 30 

different languages, as needed. Messages are automatically translated based on the 
receiving party’s language preferences. 

◦ Messages can be manually translated when clicking “Edit Translations” from the 
Compose tab, Templates tab, Announcements tab, Scheduled tab, and Drafts tab. 
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• Added the “SMS Character Limit” setting to Setup > System Preferences > Default School 
Preferences tab, which allows districts to determine the maximum number of characters 
allowed in creating and attaching text messages to messages in Communication. The default 
number of characters allowed is 130 and cannot exceed 160 characters. 

• Added the “Import Recipients / View Imported” button, which allows users to import 
recipients via a CSV file and view imported recipients once the importation is complete. 
 Importing recipients from a CSV file is useful when sending messages to external users and/
or students and parents who do not currently have access to Focus. This functionality has 
been added to the Compose tab, the Scheduled tab, and the Drafts tab 
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• Updated so when “Add Log Record” is selected and the message/email is Printed, the 
function of printing the letter is logged in the student’s Letter Log via Student Info. 

 See Communication for detailed information. 

Communication Reports (New) 

Added the Communication Reports screen, which displays a log of all sent messages including 
the Type of message, Date, Sender, Recipient(s), Total, Sent, Errors, Email (message sent), SMS 
sent, TTS, and included Audio.Note: The report includes information about SMS, TTS, and Audio, 
if the district has purchased and enabled the Call Out System. For more information on 
purchasing the Call Out System add-on module, contact the district's representative to set up a 
demonstration. 
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• Added the following profile permissions via Users > Profiles > Students tab, which 
determines if users have access to the report and to view records of messages sent by other 
users: Communication Reports (View and Edit), and View All Users. 

• Added the option to “Show All Records,” which allows users (with permission) to view all 
messages sent by all users in the school or district depending on the user’s accessibility. 

• Added the “Flagged” message indicator, which displays as selected if the message was 
flagged from the Communication screen. 

• Added the “Admin Flagged” check box, which allows administrative users to flag the message 
upon reviewing the message from this report. 
◦ Teachers are able to initiate a referral directly from their inbox when a message is 

flagged as inappropriate. 

 See Communication Reports for detailed information. 

SIS/ERP 

General 

Added the ability for browser tabs or windows to have different active sessions values without 
the user receiving the Recover Options message. This includes different packages (SIS, ERP), 
roles (administrator, teacher, parent, student), schools, school years, marking periods, progress 
periods, course periods, selected users, and selected students. 
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• When switching between tabs or windows with different session values, the values that are 
different will flash briefly to draw the user’s attention to them. 

• When the user logs out or their session expires, only active or visible tabs/windows will 
redirect to the login screen. This gives the user a chance to log back in on the active tab/
window without losing their progress on the other tabs/windows. The inactive tabs/windows 
will only redirect to the login page if the user switches over to them while still logged out. 

• This logic similarly applies if the user logs back in under a different username. The tab/
window reloads the current page. The standard menu permissions within Focus will 
determine if the user can still access that page. 

• The “Log In As” functionality is treated the same as logging out and back in under a different 
username when redirecting the tabs/windows. 

Other Changes 

SIS 

General 

Student Info, User Info, Referrals 

• Added options to change the layout to one column, two columns, or three columns. For 
Student Info and User Info, the layout can be set for each category. Note: The default for the 
Student Info Layout can still be set in My Preferences; the new layout buttons in Student Info 
will override the My Preferences setting. 
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 See Student Info and User Info for detailed information. 

Grades 

Gradebook 

Updated so that the "Not in Class" indicator displays in the teacher’s Gradebook for all classes 
attached as child sections to the primary homeroom/attendance generating period. 

Graduation Requirements Report 

Updated so that alert icons now display next to student names on the Graduation 
Requirements Report in the list view. 

 See Graduation Requirements Report for detailed information. 

Parent/Student Portal 

Communication (New) 

Added the Communication module, which replaces Messenger and allows parents and students 
to compose messages, view inbox of sent messages, view messages sent to other users, and 
save and view drafts. 
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• Added the following profile permissions to Users > Profiles > My Information tab for the 
Role: Parent and Role: Student: Communication and Send Messages. 
◦ If parents and students don’t have permission to "Send Messages," all received messages 

will be viewable via Communication > Inbox where replies can be sent. However, all other 
tabs will be hidden disallowing students and parents from composing and drafting 
messages. Note: In order to receive messages, parents and students must have access to 
"Communication." 

◦ Parents and students must have permission to "Send Messages" in order to send any 
messages or respond to received messages. 

• Added the “Compose” tab, which allows parents and students to write messages to be sent 
to selected teachers. Messages can be saved as draft, printed, or sent. 

• Added the “Inbox” tab, which allows parents and students to view messages sent to them 
and send replies. 

• Added the “Sent” tab, which displays all messages sent to other users. 
• Added the “Drafts” tab, which houses all messages saved as drafts from the Compose tab, 

and allows students and parents to create drafts. 

 See Communication (Parents/Students) for detailed information. 

Preferences 

Updated the Portal Student Name Format nickname option to “Preferred First Name Preferred 
Last Name.” The name format options are student fields, which are customizable and can 
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display as needed by districts via Students > Student Fields; i.e. users have the ability to edit the 
field Titles. 

 See Add a Student, Student Info, Student Fields, and Preferences (Students/Parents) 

for detailed information. 

Scheduling 

Courses & Sections 

(Florida only) Updated so that an error message displays when attempting to Save and the 
Inclusion Minutes Weekly are greater than the Class Minutes Weekly. 

Elementary Scheduler 

Added the ability to include race as a scheduling factor in the Elementary Scheduler. Select the 
“Race” option in the pull-down at the top-left of the screen to include race as a scheduling 
factor. 

 See Elementary Scheduler for detailed information. 
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Setup 

Application Editor 

• Updated the Student Re-enrollment Setup tab: 
◦ The Required Forms and Available Forms tables have been combined into one “Required/

Available Forms” table. The “Optional Form” check box is now used to determine if a form 
is required or optional. 

◦ Added a new column “Require Custody.” When this check box is selected along with the 
“Parent Portal” check box, only the linked user that has been flagged as custodial contact 
can access the form. 

◦ Added the following new columns: 
▪ Publish Date, Publish Time - Enter the date and time the form will be available. 
▪ End Date, End Time - Enter the date and time after which the form will no longer be 

available. 
▪ Student Profiles - If the form is published to the Student Portal, select the student 

profiles who can view and complete the form. 
▪ Parent Profiles - If the form is published to the Parent Portal, select the parent profiles 

who can view and complete the form. 

 See Application Editor for detailed information. 

Copy School 

• Added the ability to select specific subjects, courses, and sections to copy to other schools. 
◦ To copy all subjects, courses, and sections from the school, select the “All Courses, 

Subjects, & Sections” check box. 
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◦ To only copy specific subjects, courses, and sections, use the new pull-downs at the 
bottom of the screen. In order for a subject to display in the Select Subjects pull-down, it 
must have a short name in Courses & Sections. 

◦ After selecting one or multiple subjects, the active courses within the subject(s) will be 
available for selection in the next pull-down. After selecting one or multiple courses, the 
active sections within the course(s) will be available for selection in the next pull-down. 

◦ Focus will check if the selected subjects, courses, and sections already exist in the target 
school(s). Only items that do not already exist at the target school(s) will be inserted. 

 See Copy School for detailed information. 

Form Builder 

Added a new translation system for Form Builder forms. 

• A new action, “Clone & Translate,” has been added to both the District Forms tab and Focus 
Forms tab of the Form Builder. When “Clone & Translate” is clicked for a form, the user can 
select the language for the new version of the form and use machine translation (Bing) for 
the initial setup of the form. 
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• After the machine translation process is completed, the new form is opened and displays 
the machine translations. The language of the form is added to the end of the Form Name, 
e.g. “Present Levels of Academic Achievement and Functional Performance (PLAAFP) 
(Spanish [SP]).” 

• A “Disable” toggle is now available in the Form Settings for translated forms only. This toggle 
is automatically enabled. The form will not be available as a translation until the user 
ensures all necessary changes have been made. The user can disable the toggle when the 
form is ready for use. 

• In the District Forms tab and Focus Forms tab, two new columns have been added, 
Language and Parent Form. The Language column displays the language of the form. For 
cloned forms, the Parent Form column displays a View link to view the original English 
(parent) form. 
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• Two new options were added to the File menu when viewing a form: Import Translation and 
Export Translation. When Export Translation is selected, a pop-up window displays to copy 
the translatable text. On the other form, the user can select Import Translation and paste 
the translated text. 

• In SSS > Manage Student, the user can select the desired Language when printing forms. The 
form and form inputs will be translated. Translated forms that have the “Disable” toggle 
enabled in the Form Builder will not be available. 

• In SSS > General, the “Multilingual Printing” option has been removed. 

 See Form Builder and General for detailed information. 
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Run Lottery 

• Added the ability to select the program(s) to run in the lottery. 

 See Run Lottery and School Choice Setup for detailed information. 

School Choice Setup 

• Added the preference “Don’t Cancel Alternate Choices” to the Customize Application - 
Magnet, SPA, and Choice tabs. When this preference is enabled, the student’s other 
applications will not be declined while running the lottery, as well as when a parent accepts 
a Pending Acceptance application on the parent portal. Additionally, the lottery will run for 
all school_choice_application_statuses at once, rather than iterating for 1 to 20. This will 
eliminate the priority for choice; all of the student’s applications will be treated equally and 
multiple acceptances for one student will be allowed. 

School Fields 

• Added a new option called “School Filter” for “select one” and “select multiple” school fields. 
When this option is enabled on a field, the select options for the field will display as tags 
which can be used as filter options within the Schools pull-down. 
◦ These tags are available in the Schools pull-down on the Student Info, Mass Assign 

Student Info, District Reports, User Info > Permissions tab, Third Party Systems, Rollover, 
Calculate GPA, Pull Grades for Report Cards, and Graduation Requirements > District 
Graduation Programs and Requirements screens. 

◦ For example, a user can set up a school field called School Committee Members, enable 
the School Filter option, and set up the school committee members as select options. In 
School Information, the school committee members for that specific school can be 
selected in the School Committee Members field. When the Schools pull-down is opened 
on one of the aforementioned screens, the school committee member select options will 
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display as tags that can be clicked to filter the list of schools. A “Match all” check box is 
available; when selected, only options that match all of the selected tags will display. 

 See School Fields for detailed information. 

System Preferences > Default School Preferences/School Preferences > 
Enrollment 

• Added a new preference “Show Preferred Name fields on Add a Student.” When enabled, the 
Preferred First Name and Preferred Last Name fields will be included in the search fields on 
the Add a Student screen and in the Primary Info category in Student Info. 
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Third Party Systems 

Added a Debug column to Third Party Systems. Clicking the “Debug” button will activate the 
corresponding vendor in the login session so that browsing to API endpoints uses that vendor’s 
configuration. This removes the need to add ?external_api_id=X to the end of URLs, though that 
functionality is still available. Click the “Clear” button at the top of the screen to clear the debug 
value if the user wants to revert back to the default configuration. 

 See Third Party Systems for detailed information. 

Students 

Computed Student Fields 

• Removed the old Computed Student Fields screen. Any computed fields set up using the 
Computed Student Fields screen will be removed from the Advanced Report. Computed 
fields are currently set up in Students > Student Fields. 

Enrollment Codes 

• Added the Application Statuses tab to the Enrollment Codes screen, which is used to set up 
application status options. These options will be available in the new Status column in 
Students > Online Enrollments > Unprocessed Applications tab. Users can select a status for 
an unprocessed application. 
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 See Enrollment Codes and Online Enrollments for detailed information. 

Online Enrollments 

• Added the ability to provide override reasons for student address changes on the Online 
Enrollments screen for districts that use the Address Catalog for verification. When an 
address change makes the student out of zone for that school, the user who approves the 
address change will be prompted to select an override reason if they have the profile 
permission “Allow overriding zoned address restrictions” for Students > Add a Student. If the 
user does not have this profile permission, the user will receive a message “You are not 
allowed to override that error.” Similarly, users with the profile permission “Allow enrolling 
out-of-district students“ will be prompted to select an override reason when an address 
change is out of the Address Catalog, while users without this permission cannot. Once an 
override reason is selected and submitted, the student's address will update in the system. 
◦ Override reasons are populated based on the system preference “Override Reason Field” 

in Setup > System Preferences > Default School Preferences/School Preferences > 
Enrollment tab. If no value is set in the system preference, the state’s default 
student_enrollment column is used. 
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 See Online Enrollments for detailed information. 

Uploaded Files 

Added the ability for districts using the add-on Document Management module to include SSS 
events and SIS Form Builder forms to the Uploaded Files screen for students. If your district is 
interested in using this functionality, please reach out to your support representative to 
schedule a demonstration. 

• The Academic Category can now be set on a form in Setup > Form Builder. 
• The Academic Category can now be set on an SSS event in SSS > Setup > Events tab. 
• When an SSS event with an Academic Category designated is locked, the PDF of the event 

forms will be included in the SSS Event Forms table on the Uploaded Files screen for the 
student. If the event is unlocked, the PDF will be removed. 

• When an SIS Form Builder form is finalized, it will be included in the Formbuilder Forms 
table on the Uploaded Files screen for the student. 

• The Letters table on the Uploaded Files screen has been updated to “Letter Log.” Letters that 
have an Academic Category designated and that have been generated and logged will be 
displayed for the student. 
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• In Users > Profiles, a new permission has been added under Student Info called “Manually 
Process Files.” Users with this permission will have access to the “Manually Process Files 
Now” button on the Uploaded Files screen. When new files are uploaded for a student and 
the files have not yet been processed, the user can click this button to process the files now 
(which allows text searching and redacting), instead of having to run the Document 
Management scheduled job. 
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 See Form Builder, Setup, and Uploaded Files for detailed information. 

Students/Users 

Student Fields, User Fields 

• Added the ability for “select one” fields to be displayed as a set of radio buttons rather than 
as a select box in Student Info, User Info, and online applications. To enable this option for a 
field, select “Display as Radio Buttons” in the Edit Field window. This preference is stored in 
the column “display_as_radio.” If a field is not marked as Required, an N/A option will be 
included in the set of radio buttons. 

 See Student Fields and User Fields for detailed information. 

Page 2812.0.0 New Feature Release Notes

https://focus.screenstepslive.com/s/admins/m/sis/l/764026-form-builder#setting-the-academic-category-on-a-form
https://focus.screenstepslive.com/s/admins/m/80557/l/948809-setup#setting-up-events
https://focus.screenstepslive.com/s/admins/m/sis/l/1575139-uploaded-files
https://focus.screenstepslive.com/s/admins/m/sis/l/824847-student-fields
https://focus.screenstepslive.com/s/admins/m/sis/l/692326-user-fields


Student Info, User Info 

• Updated so that the icons that are set on categories in Student Fields or User Fields display 
next to the category name in the list on the left side of the screen for easier identification. If 
a color and icon is not set on a category, a default icon will display. 

 See Student Info and User Info for detailed information. 

Teacher Portal 

Communication (New) 

Added the Communication module to the Students menu, which replaces the Messenger and 
Phone Communication screens. Note: The features within Communication, such as Phone 
Communication (Call-Out System) and Translations, require additional purchases. Contact the 
district's support representative to set up a demonstration. 

Page 2912.0.0 New Feature Release Notes

https://focus.screenstepslive.com/s/admins/m/sis/l/643897-student-info
https://focus.screenstepslive.com/s/admins/m/sis/l/1666790-user-info


• Added Communication profile permission to Users > Profiles > Students tab, which includes 
the following permissions for Role > Teacher: Communication, Send Messages, Class 
Announcements, Send SMS, and Phone Calls. Note: The SMS and Phone Calls features 
require additional purchase by the district. Contact the district's support representative to 
set up a demonstration. 

• Added the “Compose tab,” which allows teachers to to create a message (Messenger) to 
selected students, use a template, create a new announcement, and/or create a new 
template. 
◦ Messages can be created manually and be assigned a Letterhead template, flagged as a 

Secure Message, and added to the Log Record. 
◦ Messages can also be discarded, saved as drafts, printed, scheduled to be sent at a later 

date and time (or set up as Recurring), and sent. 
◦ Files, multimedia messages (SMS), recorded messages, and text-to-speech messages can 

be added to messages, as well. Note: The SMS and Phone Calls features require 
additional purchase by the district. Contact the district's support representative to set up 
a demonstration. 

◦ Added the ability to send messages to Students, Student Personal, Primary Contacts, All 
Contacts, Once Per Family, Students & Primary Contacts, Students & All Contacts, and 
Teachers Of. 

◦ The “All Contacts” option includes all users and/or persons in a student’s addresses & 
contacts. The “Primary Contacts” option limits to the contacts marked as custody. 

◦ Updated the “Once Per Family” option so students must be linked to contacts, contacts 
must have custody of one of the linked students, and contacts must have an email 
address. 

◦ Updated so if a student does not have a contact and contacts are selected as the 
recipient, the student will get the message instead. 
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• Added the “Templates” tab, which gives teachers the ability to create templates and use said 
templates to generate messages to students (previously known as Messenger and Phone 
Communication). 
◦ Templates include a Title, Letterhead, and a Secure Message option, which flags 

messages as secure and requires users to log into Focus in order to view the message. 
◦ Emails, files, multimedia messages (SMS), recorded messages, and text-to-speech 

messages can be added to templates, as well. Note: The SMS and Phone Calls features 
require additional purchase by the district. Contact the district's support representative 
to set up a demonstration. 

• Added the “Announcements” tab, which allows teachers to enter a Title, assign Sections, 
establish a Publish time frame for when the message should display on select Portal screens 
as a Class Announcement. From the Announcements tab, new announcements can be 
created and posted to the selected students in a section. Announcements can also be 
discarded and posted. 
◦ Emails (messages), files, test messages (SMS), recorded messages and text-to-speech 

messages (Call) can be sent with announcements, as well. Note: The SMS and Phone Calls 
features require additional purchase by the district. Contact the district's support 
representative to set up a demonstration. 

• Added the “Inbox” tab, which houses all incoming messages from which a chat is displayed 
with all incoming and outgoing messages between the user and the applicable users or 
students. 
◦ Upon sending messages from the Inbox tab, users have the option to create a new 

message, schedule a time and date for the message to be sent, and send messages 
instantly, in addition to viewing incoming messages. 
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◦ When messages are received, a Portal Alert displays the number of unread messages; 
when clicked, Focus navigates to the Inbox where unread messages display users’ names 
and the number of unread messages. 

• Added the “Sent” tab, which houses all sent messages from which a chat is displayed with all 
outgoing and incoming messages between the user and the applicable users or students. 
◦ Upon sending messages from the Sent tab, users have the option to create a new 

message, schedule a time and date for the message to be sent, and send messages 
instantly. 

• Added the “Scheduled” tab, which houses all messages that have been scheduled to be sent 
out at a later date and/or time. Scheduled messages can be sent manually before their 
scheduled date and time, as needed, as well as created and edited exactly like a new 
message. Note: Emails are sent out when the message is scheduled; however, calls and text 
messages still respect the “Do Not Send Calls Before This Time” and the “Do Not Send Calls 
After This Time” system preferences set via Setup > System Preferences > Default School 
Preferences > General. 

• Added the “Drafts” tab, which houses all messages saved as drafts. From the Drafts tab, 
users can schedule, send, or edit messages, as well as perform all other tasks as if creating a 
new message. 

 See Communication for detailed information. 
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Communication Reports (New) 

Added the Communication Reports screen, which displays a log of all sent messages including 
the Type of message, Date, Sender, Recipient(s), Total, Sent, Errors, Email (message sent), SMS 
sent, TTS, and included Audio. Note: The report includes information about SMS, TTS, and 
Audio, if the district has purchased and enabled the Call Out System. For more information on 
purchasing the Call Out System add-on module, contact the district's representative to set up a 
demonstration. 

• Added Communication Reports profile permission to Users > Profiles > Students tab, which 
includes the following permissions for Role > Teacher: Communication Reports (View). 

• Added the “Flagged” message indicator, which displays as selected if the message was 
flagged from the Communication screen. 

• Added the “Admin Flagged” check box, which allows administrative users to flag the message 
upon reviewing the message from the report. 
◦ Teachers are able to initiate a referral directly from their inbox when a message is 

flagged as inappropriate. 

 See Communication Reports for detailed information. 

Users 

Calendar 

Added the “Type” pull-down when adding an event or recurring event to the calendar. The Type 
pull-down allows users to add an SSS service to a student or create a log record for a student 
from a calendar event. 

• The SSS Service check box has been removed. Users with the Edit profile permission for 
Services in Caseload & Services can select “SSS Service” from the Type pull-down. After the 
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event is saved, the user can click the event, click “Add New Service,” and add a service for the 
student to the Caseload & Services screen, as was the previous functionality. 

• The Type pull-down also allows users to add a log record to a logging field for a student from 
a calendar event. The pull-down includes all of the student logging fields the user has 
permissions to create records for that have a date and time field. 

• When a logging field is selected, the logging field is displayed in the event window. The user 
can set default values for the log record as needed. 
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• In the Upcoming Events block on the Portal, events with a logging field selected have a green 
plus sign next to them. When the green plus sign is clicked, a pop-up window displays the 
log record. Any default values entered by the user on the event are populated. The current 
date and time are also populated into the logging field. The user will complete the log record 
and click Create to add it to the student’s record. 

 See Calendar (Admin) and Calendar (Teachers) for detailed information. 
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My Preferences/Preferences 

• Updated the student “Nickname” field to be called “Preferred First Name.” This updates the 
student field as well as the Student Name Format options in My Preferences/Preferences > 
Student Listing tab. Additionally, the “Preferred Last Name” student field has been added. 
This displays along with the “Preferred First Name” field in the Primary Info category in 
Student Info. 
◦ Added a new Student Name Format option in My Preferences/Preferences > Student 

Listing tab called “Preferred Last Name, Preferred First Name.” 
◦ When the “Preferred Last Name” option is selected in My Preferences/Preferences, this 

will function similarly to the Preferred First Name field; if the field is null, the last_name 
will be used in its place. 

◦ When the “Preferred Last Name” option is selected in My Preferences/Preferences, the 
Preferred Last Name will display on all user, staff, and student screens like it does with 
the Preferred First Name field; this includes but is not limited to Take Attendance, Post 
Grades, and Student Info. The Preferred First Name and Preferred Last Name will also 
display in student pull-downs. 

Profiles 

• Removed the Messenger and Portal Messages permissions from the Setup tab because 
Messenger and Portal Messages have been replaced with the new Communication module; 
the following permissions have been removed: 
◦ Messenger: “Messenger: Allow Access,” “Messenger: Include Profile in Search,” and 

“Messenger: Send Messages.” 
◦ Portal Messages: “Portal Messages” and “Allow Push Notifications & Public Messages.” 

SIS / ERP 

General 

Updated so that the first five numbers in student and user Social Security numbers are masked 
with asterisks. A new profile permission “View Full SSN” will allow users to view the full Social 
Security number for students. 

• This change affects: 
◦ Students > Student Info 
◦ Users > User Info 
◦ Students > Advanced Report 
◦ Users > Advanced Report 
◦ Student online application and re-enrollment forms 
◦ Scheduling > Print Class Lists 
◦ Students > Print Student Information > Classified 
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◦ Students > Print Avery Labels 
◦ Users > Print Avery Labels 
◦ Students > Print Letters & Send Email 
◦ Users > Print Letters & Send Email 
◦ Setup > Letterhead Templates 
◦ Report cards 
◦ Setup > Form Builder > Headers (custom headers) 
◦ Student/Parent Portal > Forms Summary > Completed Forms > View Changes button 
◦ ERP > Human Resources > Applicant Tracking 

• Users with the new profile permission “View Full SSN” for students will be able to view full 
student Social Security numbers. Users that have this permission enabled will be able to edit 
Social Security numbers for students in an Advanced Report. Users without this permission 
will have read-only access to the masked Social Security numbers in the Advanced Report, 
regardless of the Edit permission to the SSN field. 

• Users with the “View Full SSN” permission for students will see the full student Social 
Security number on a generated document/report if the template includes the student 
Social Security number field. 

• User Social Security numbers are always masked in the SIS. User Social Security numbers are 
not editable in the Advanced Report. Changes to user Social Security numbers can be made 
in User Info for those with Edit permission to the field. The Social Security number will be 
masked after it is edited and saved. 

• In Students > Audit Trail and Users > Audit Trail, all digits will display in the Social Security 
number. Additionally, custom district reports will display all digits. 

• ERP > Setup > Settings > Payroll > “Display SSN in Employee Dropdown” continues to work in 
the same fashion as before. User Social Security numbers are not masked for users with 
View and Edit access to this employee field (556). 

Added an “Exact” check box to the filter in select multiple pull-downs. Select “Exact” to only see 
exact matches when entering text in the filter. The style has also been updated for select one 
and select multiple pull-downs. Additionally, the search algorithm when filtering within a pull-
down has been improved. 
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ERP 

Fixed Assets 

Added the “Edit Department” permission to Setup > Profiles > Fixed Assets tab, which 
determines which users who have access to the “Department” pull-down in Manage Assets 
upon creating and editing assets and Receive Transfer upon receiving an asset transfer. 

 See Manage Assets and Receive Transfer for detailed information. 

Human Resources 

Online Applications 

• Added a profile permission for each tab, so only users with permission to each tab can view 
the applicable information held within said tab, add comments on select tabs, approve or 
deny applications, and delete applications. The following permissions have been added via 
Setup > Profiles > Human Resources tab: 
◦ View Unprocessed Applications 
◦ View Unsubmitted Applications 
◦ View Processed Applications 
◦ View/Leave Comments on Unprocessed Applications 
◦ View/Leave Comments on Unsubmitted Applications 
◦ View/Leave Comments on Processed Applications 
◦ Approve/Deny Unprocessed Applications 
◦ Approve/Deny Unsubmitted Applications 
◦ Approve/Deny Processed Applications 
◦ Delete Unprocessed Applications 
◦ Delete Unsubmitted Applications 

 See Online Applications for detailed information. 

SSS 

Added the ability for parents to view SSS documents from locked events in the Parent Portal. 
Also added the ability for parents to view and sign SSS forms that need the parent signature. 
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• SSS > Setup > Events tab - Added the option “Publish to Parent Portal.” When this option is 
selected for an event, the event is published as a PDF to the Parent Portal. 

• When an event that has the “Publish to Parent Portal” option enabled is locked, the user is 
asked “Do you want to publish to parent's portal?“ If the user clicks Cancel, the event is 
locked, but the document is not published to the Parent Portal. If the user clicks Yes, the 
event is locked and the following occurs: 
◦ The parent receives an alert in the Alerts box on the Parent Portal: “A Student Service 

document (event name) has been published for your review for your student (student 
name).” 

◦ Clicking the alert opens the Reports tab in the student block on the Portal. The document 
is displayed in the Student Services section of the Reports tab. It includes the link to the 
document, the Date Published (when the event was locked), and the Date Viewed (when 
the parent last viewed the linked document). 

◦ Clicking the document link opens a PDF of the event forms in a new tab. The alert is 
removed from the Alerts block once the parent opens the document. 

◦ If a user unlocks the event, or deletes the event, the alert and document is removed from 
the Parent Portal. 

• Setup > Scheduled Jobs - Added a new scheduled job called “SSS Parent Portal Notifications” 
which is used to send an email to the parent (contact priority of 1) if an SSS alert remains 
unread for 24 hours. 

• Setup > Form Builder -  Added a new option “Signable by Parent” for E-Signature 
components. Enable this option for parent signature fields on the appropriate forms. 

• Users > Profiles - Added the “Student Services” View permission for parent profiles in order 
for parents to access the new Student Services screen in the Parent Portal. 

• SSS > User Profile Permissions > System Permissions tab - Select the “Allow” permission for 
“View Events” for the parent profile for the appropriate programs. 

• SSS > User Profile Permissions > Event Permissions tab - Select the “View All” and “Edit All” 
permissions for the parent profile for the appropriate events. 

• When a form that contains a “Signable by Parent” e-signature component is saved and 
validated by a user, the parent receives an alert in the Alerts box on the Parent Portal: 
“Signature required in a student service event for (student name).” 
◦ When the parent clicks the alert, the Student Services screen is opened for the event. 
◦ At the top-right corner of the screen, a blue “Click to Sign” button is displayed. Clicking 

this button navigates the parent to the page where the e-signature component is located. 
The e-signature component is also highlighted. The parent will click the e-signature 
component, authenticate their signature, and sign. No other fields will be editable by the 
parent. The parent will click Save & Validate after signing. 

◦ After completing the parent signatures, the alert will be removed from the Portal. 
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 See Student Services, Setup > Events tab, Manage Student, Form Builder, Parent Portal, 

and Scheduled Jobs for detailed information. 
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